Перенос конфигурации Cisco catalyst c помощью tftp сервера.

Чтобы каждый раз не настраивать с нуля новый коммутатор, который появляется в моем хозяйстве, я держу файлик с базовым конфигом и заливаю его на коммутатор через tftp. Процедура достаточно тривиальная. Под Windows, как и большинство моих коллег, я использую простой tftp сервер tftpd32, на его примере я и продолжу дальнейший рассказ, для Linux это штатный демон, tftpd, как нибудь об этом тоже расскажу. Итак для начала, допустим у нас есть сконфигурированный коммутатор, и нам нужно скачать с него конфиг. Делается это очень просто запускаем на машине tftp сервер:    Соответственно указываем путь к папке, tftp сервера (я создал в корне диска C: папку с именем tftp) и IP адрес.

tftp

Естественно коммутатор должен быть доступен, с машины на которой запущен tftp сервер. Теперь заходим на коммутатор и выполняем команду копирования стартовой конфигурации на tftp сервер:

c3560-4#copy startup-config tftp

после этого будет инициализирован диалог, где устройство спросит вас IP tftp сервера, и под каким именем вы бы хотели сохранит файл, если не отвечать на второй вопрос конфиг сохранится под именем, которое предложит сам каталист:

Address or name of remote host []? 192.168.200.84
Destination filename [c3560-4-confg]?

после этого начнется копирование, после копирования коммутатор скажет что то вроде этого:

!!
11600 bytes copied in 0.135 secs (85926 bytes/sec)

а в окне tftp сервера что то вроде этого:

tftp_progress




После этого, конфиг оказался в папке сервера, и его можно открыть текстовым редактором. После того как конфиг подправлен соответствующим образом можно заливать его на новый коммутатор, для этого сначала нужно включить его в сеть и дать ему IP адрес, процедуру настройки адреса на коммутаторе я описывал в статье посвященной начальной настройке коммутатора cisco. Выношу кусок настройки из этой статьи:

В рядовых случаях управление устройствами выносят в отдельный VLAN, в моем случае это VLAN 100, нужно объявить его на коммутаторе и задать порты которые являются членами данного VLAN, итак:

Switch(config)#vlan 100
Switch(config-vlan)#name "** Management"
Switch(config-vlan)#exit
Switch(config)#interface gigabitEthernet 1/0/21
Switch(config-if)#switchport access vlan 100
Switch(config-if)#exit

Мы объявили 100 VLAN дали ему имя «** Management» и сделали порт 21 его членом, теперь назначим коммутатору IP адрес 10.10.10.116 в этом влане.

Switch(config)#interface vlan 100
Switch(config-if)#ip address 10.10.10.116 255.255.255.0
Switch(config-if)#exit

Если компьютер с которого вы будете управлять на коммутатором находится в этой же подсети, то этого достаточно, но в моем случае все не совсем так, я попадаю в эту подсеть через маршрутизатор, поэтому нужно указать на коммутаторе адрес шлюза:

Switch(config)#ip default-gateway 10.10.10.1

Теперь можно испытать доступность коммутатора, подключив его 21 портом в нужную нам сеть и проверив доступность. После того как коммутатору присвоен адрес и он доступен можно заливать на него конфиг, при этом у нас должен быть запущен tftp сервер, итак поехали:

copy tftp startup-config

после этого, как и ранее, будет инициирован диалог, где устройство спросит адрес сервера, название файла с конфигом и под каким именем этот файл сохранить:

Address or name of remote host []? 192.168.200.84
Source filename []? c3560-4-confg
Destination filename [startup-config]?

после того как мы ответим на все вопросы, увидим примерно следующее:

Accessing tftp://192.168.200.84/c3560-4-confg...
Loading c3560-4-confg from 192.168.200.84 (via Vlan100): !
[OK - 11269 bytes]

11269 bytes copied in 8.363 secs (1347 bytes/sec)
Switch#

Все, файл залился на место стартового конфига кошки, теперь при следующей загрузке она загрузится с этим конфигом. Можно сделать несколько иначе, а именно залить конфиг не в startup-config а просто на флеш-память под любым именем а затем сказать коммутатору, чтобы он грузился с этого конфига:

boot config-file flash:/config.text

после перезагрузки (не зависимо от метода по которому вы залили конфиг) железяка загрузится с нового конфига.

Перенос конфигурации Cisco catalyst c помощью tftp сервера.: 2 комментария

  1. Switch(config)#vlan 100
    Switch(config-vlan)#name «** Management»
    Switch(config-vlan)#exit
    Switch(config)#interface gigabitEthernet 1/0/21
    Switch(config-if)#switchport access vlan 100
    это еще надо писать — Switch(config-if)#switchport mode access
    Switch(config-if)#exit

    1. В данном случае это не очень принципиально, т.к. порт используем только 1 раз для того, что бы залить конфигурацию на коммутатор. Но в принципе по правилам хорошего тона и в целях безопасности нужно конечно явно прописывать на портах mode и switchport nonegotiate. Так же на портах, которые смотрят в сторону конечного пользователя имеет смысл отключать cdp. В общем случае конфигурация порта будет выглядеть примерно вот так:

      interface FastEthernet0/1
      description «end user»
      switchport access vlan 123
      switchport mode access
      switchport nonegotiate
      no cdp enable

      В статье ваше замечание учел.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *