Trunk порты Juniper SRX

Я как то уже описывал, как создать VLAN интерфейс на SRXе. Часто требуется создавать порты с тегированными VLAN.

Тут есть 2 способа, 1 способ просто trunk интерфейс или 2 способ создать VLAN а за тем присвоить его интерфейсу или группе интерфейсов. Какой способ использовать решать вам, вопрос только в удобстве настройки и дальнейшего администрирования. Я использую 2 способ в связке с кластером из 2-х устройств, объединяю порты разных нод в групу и настраиваю ее. Кажется немного запутанно но думаю по ходу станет понятней, в принципе сложного здесь ничего нет. Итак:

1 способ.

В настройках интерфейса прописываем то что он работает с тегированными VLAN:

admin@SRX# set interfaces ge-0/0/1 vlan-tagging

после этого создаем сабинтерфейсы и указываем VLAN ID для каждого из них:

admin@SRX# set interfaces ge-0/0/1 unit 100 vlan-id 100

ну и, соответственно можно настроить сабинтерфейсы в зависимости от нужд, например присвоить им какой то IP:

admin@SRX# set interfaces ge-0/0/1 unit 100 family inet address 192.168.0.1/24

таким образом у нас есть интерфейс ge-0/0/1 на котором есть тегированный VLAN 100

аналогично можно добавить сабинтерфейсы с другими VLAN, я проделал тоже самое для VLAN 101. Номер unit не обязательно должен совпадать с VLAN ID, в данном примере я сделал их одинаковыми для удобства.
Интерфейс выглядит следующим образом:

admin@SRX# show interfaces ge-0/0/1
vlan-tagging;
unit 100 {
 vlan-id 100;
 family inet {
 address 192.168.0.1/24;
 }
unit 101 {
 vlan-id 101;
 family inet {
 address 192.168.1.1/24;
 }
}

Вот и вся настройка.



2 способ.

часть команд этого способа описана в статье о создании VLAN интерфейсов, о которой я говорил в начале

Как я уже говорил выше, этот способ сложнее длиннее в настройке, но мне кажется более гибким и изящным. А по настройке вполне логичен, настройку можно разбить на 3 шага:

1 шаг — настройка L3 интерфейсов для VLAN:

admin@SRX# set interfaces vlan unit 100 family inet address 192.168.0.1/24

здесь как и в предыдущем примере номер unit тоже может быть любой, я сделал его таким же как номер VLAN для удобства чтения конфига.

2 шаг — настройка VLAN:

Тут указываем имя VLAN его ID и L3 интерфейс который нужно к нему привязать:

admin@SRX# set vlans vlan-100 vlan-id 100 l3-interface vlan.100

Тут так же имя VLAN может не совпадать с VLAN ID, я сделал их схожими для удобства.

3 шаг — настройка физического интерфейса:

admin@SRX# set interfaces ge-0/0/1 unit 0 family ethernet-switching port-mode trunk vlan members vlan-100

Если нужно указать несколько VLAN, то это делается через пробел в квадратных скобках: [ vlan-100 vlan-101 ]

Аналогично можно проделать для других VLAN, я проделал тоже самое для 101 VLAN, в итоге конфигурация имеет следующий вид, интерфейсы:

interfaces {
 ge-0/0/0 {
  unit 0 {
   family ethernet-switching {
    port-mode trunk;
    vlan {
     members [ vlan-100 vlan-101 ];
    }
   }
  }
 }
 vlan {
  unit 100 {
   family inet {
    address 192.168.0.1/24;
   }
  }
  unit 101 {
   family inet {
    address 192.168.1.1/24;
   }
  }
 }

И VLANы:

vlans {
 vlan-100 {
  vlan-id 100;
  l3-interface vlan.100;
 }
 vlan-101 {
  vlan-id 101;
  l3-interface vlan.101;
 }
}

Команды для просмотра

Интерфейсов в свитчинге:

admin@SRX> show ethernet-switching interfaces
Interface    State  VLAN members        Tag   Tagging  Blocking
ge-0/0/0.0   up     vlan-100            100   tagged   unblocked
                    vlan-101            101   tagged   unblocked

VLAN интерфейсов:

admin@SRX> show interfaces vlan terse
Interface               Admin Link     Proto    Local                 Remote
vlan                    up    up
vlan.100                up    up       inet     192.168.0.1/24
vlan.101                up    up       inet     192.168.1.1/24

В случае использования этой конфигурации в связке с кластером обычно объединяются интерфейсы разных нод в ethernet switching (при этом обязательно при сборке кластера нужно предусмотреть порты swfab) а дальнейшая настройка аналогична, вот так выглядит группа интерфейсов, настроенная таким образом:

interface-range range1 {
 member ge-0/0/2;
 member ge-5/0/2;
 unit 0 {
  family ethernet-switching {
   port-mode trunk;
   vlan {
    members [ vlan-100 vlan-101 ];
   }
  }
 }
}

Range1 это название группы интерфейсов, оно может быть любым.

Во избежание ошибок, пользуйтесь commit check и commit confirmed, успехов.

Trunk порты Juniper SRX: 6 комментариев

  1. А есть способы настройки нетегированного trunk-порта для Juniper J2320? 1 способ был прописан применительно для нетегированного трафика flexible-vlan-tagging. Коммитится, но не работает. Цель: нужно из одного порта Juniper J2320 транслитровать 2 подсети. Juniper этим портов подключен к коммутатору, от которого эти 2 подсети транслируются на компьютеры и IP-телефонию.

    1. Александр, поясните, пожалуйста, что имеется ввиду под «нетегированным trunk-портом»? Если я правильно понял схему описанную Вами, то достаточно trunk порта в сторону коммутатора с соответствующими VLAN ID, на коммутаторе порт настраиваем аналогичным образом (тоже trunk порт с теми же VLAN ID). Такую конфигурацию проверял на опыте, правда не с J-серией а с SRX.

  2. Доброе времени суток у меня проблема на srx 100b после команды «restart web-management» аппарат сбросил все настройки до заводских у меня осталось файл из другого коммутатора hp v1910 вопрос такой как то можно определить настройку srx 100b.
    Заранее спасибо

    1. Попробуйте посмотреть среди rollback конфигураций нужную вам. Набрав в консоли команду rollback затем ? увидите список доступных роллбэков. Сможете определить по времени.
      Только не совсем понял, какое значение имеет в данном случае коммутатор HP. Думаю его наличие/отсутствие никак не влияет на восстановление конфигурации SRX.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *